Page 1 of 1

Z3950 Error

Posted: 25 Dec 2016, 18:45
by RKMSLIMS
Hello Moderators,

When I try to search using Z3950 SEARCH/RETRIEVE VIA URL (SRU) I get below error, where am I going wrong? please help.
Warning: SimpleXMLElement::__construct(): php_network_getaddresses: getaddrinfo failed: No such host is known. in D:\psenayan\apache\htdocs\akasia\admin\modules\bibliography\z3950sru.php on line 196

Warning: SimpleXMLElement::__construct(http://z3950.loc.gov:7090/voyager?versi ... chema=mods): failed to open stream: php_network_getaddresses: getaddrinfo failed: No such host is known. in D:\psenayan\apache\htdocs\akasia\admin\modules\bibliography\z3950sru.php on line 196

Warning: SimpleXMLElement::__construct(): I/O warning : failed to load external entity "http://z3950.loc.gov:7090/voyager?versi ... chema=mods" in D:\psenayan\apache\htdocs\akasia\admin\modules\bibliography\z3950sru.php on line 196

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in D:\psenayan\apache\htdocs\akasia\admin\modules\bibliography\z3950sru.php:196 Stack trace: #0 D:\psenayan\apache\htdocs\akasia\admin\modules\bibliography\z3950sru.php(196): SimpleXMLElement->__construct('http://z3950.lo...', 8192, true) #1 {main} thrown in D:\psenayan\apache\htdocs\akasia\admin\modules\bibliography\z3950sru.php on line 196

Also please tell me how to install YAZ, I get below error,
YAZ extension library is not loaded/installed yet. YAZ library is needed to use z3950 enabled service. Please refer to official YAZ PHP Manual on how to setup/install YAZ extension library in PHP.
I am using Slims portable version Akasia 8.3

Any help will be greatly appreciated.