Fatal Error Message After Installation

Write everything here about installation of SLiMS.

Moderators: wynerst, buitenzorg812, purwoko, sutriadi, ido, Dicarve, ridorido

Post Reply
tundeogidi
Posts: 2
Joined: 09 Oct 2016, 20:12

Fatal Error Message After Installation

Post by tundeogidi » 24 Oct 2016, 07:22

Hi,

Please I need help with my installed copy of SLiMS.
After I installed it successfully on the server, opening the homepage and the Admin page is giving a fatal error as pasted below;
---
Fatal error: Call to undefined function mb_detect_encoding() in /home/oyotechorg/public_html/elibrary/lib/lang/php-gettext/gettext.inc on line 177
---

I initially thought its because Gettext was not installed so I recompiled my Apache and enabled gettext and still, I am getting the same error.

Please can anybody help out.

The version of SLiMS is 8.3 and it is installed on Centos Linux server with PHP version of 5.6.26.

Thank you.
Olatunde

User avatar
buitenzorg812
Posts: 830
Joined: 20 Sep 2011, 14:18
Location: Jakarta, Indonesia
Contact:

Re: Fatal Error Message After Installation

Post by buitenzorg812 » 26 Oct 2016, 18:21

try this, http://stackoverflow.com/questions/1720 ... t-encoding. the first method seems legit, by installing php-gd. hope it helps :).

tundeogidi
Posts: 2
Joined: 09 Oct 2016, 20:12

Re: Fatal Error Message After Installation

Post by tundeogidi » 27 Oct 2016, 16:55

Thank you so much for your help.

The issue is now resolved and everything works fine.

The error was always related to PHP being unable to load the php_mbstring extension, because of some issue with the “php_mbstring.dll” file, or the environment…
I simply enabled php_mbstring extension and everything was fine.

User avatar
buitenzorg812
Posts: 830
Joined: 20 Sep 2011, 14:18
Location: Jakarta, Indonesia
Contact:

Re: Fatal Error Message After Installation

Post by buitenzorg812 » 30 Oct 2016, 22:03

wow that's great. hope you can write down your experience, troubleshooting problem in SLiMS installation, so everybody can learn from you :). thank you.

Post Reply